Android App Installation Trouble / Supported Devices


#1

Hi,

My dev boards are on the way, set to arrive on Monday. I just tried installing the android app on my OnePlus One and I’m running into trouble. The Google Play store is unable to install the app on my device, showing “item not found”, however when visiting the Google Play page for the Afero app on my laptop, it tells me that the app is compatible with my OnePlus.

I’m curious if you know why the installation is failing? Are One Plus devices officially supported? I’m well-aware that development for Android is a pain because of the vast number of different devices, so thanks in advance for any additional effort you can put in to resolve this.

Cheers,
-Jonathan


#2

Hey Jonathan!

Thanks for letting us know – we’ve got the app guys looking into it right now. As soon as I hear back from them I’ll let you know what we find out!

Cheers,

Joe


#3

Awesome - Thanks so much!


#4

By the time I posted the first reply, I had an answer for you!

The One Plus One is supported by the app. We can think of two reasons why it might be giving you that Item Not Found error though, so there’s a couple of simple things you can try:

  1. If you signed up as a tester with a different account than you’re signed into the Play store with, that would give you the error message you’re seeing. That’s probably not the case, but it’s worth making sure the account you signed up as a tester is the one actually logged into the store at this time.

  2. If you signed up as a tester very recently, we’ve seen some cases where it takes a little bit of time for that to propagate through all of the store systems. So if you’re using the right account in the Play store, but you /just/ got signed up as a tester (like maybe in the last couple of hours), it may be worth trying it a little later after everything on the backend has had a chance to catch up.

Failing all else, you could also try installing it from your PC. If it says the app is compatible with your device, it should get you the option right there to install it.

Let me know if any of that works for you, or (heaven forbid!) if not, we’ll see what else we can do for you.

Thanks for signing up, we’re looking forward to seeing what you can do with our cool new platform! :smile:

Cheers,

Joe


#5

Thanks for the quick reply! I’m up and running now, not sure if it was the timing issue mentioned in #2 or if I wasn’t paying attention to the user account that the Google Play store was using the first time I tried. But I’m all set now :smile:

I imagine you’ll see more of me on the forums next week once I’ve got hardware in my hands and I’m breaking things left and right.

Cheers,
-Jonathan


#6

Very cool!

I’m willing to bet it was just a delay in propagating that tester status through the backend. We’ve seen it before, we’ll see it again.

And feel free to ask away! We’re really just getting this stuff out to the Teeming Millions and we’re excited to see what things you can do with the platform! :smile:

We have a couple of example projects that we’ll be posting up on the forum next week to go give you (and everyone) some idea fodder.

Cheers,

Joe