Problem linking the Modulo to the Mobile App


#1

I got the Modulo 4 days ago and was able to turn the Modulo LED on and off with the mobile app from Lesson 1. I am trying it again today, but cannot connect to the device. Looking at the mobile app, it says that the Device is offline. I’ve got Bluetooth turned on on my phone. The Module has power, but the device still appears to be offline. When I plug the micro USB into the Modulo, the LED turns on for a second, so I know the board is getting power. Any suggestions as to why the device is offline?


#2

Hey Mike!

Very odd. Should be pretty much plug and play as you’ve seen before. The LED blink on power up shows that the Modulo is resetting, so it SHOULD be trying to come online.

We can check the Modulo pretty quick if you want to try a quick test. The Modulo USB port also presents a serial port to your PC. Grab your favorite serial terminal program, if you have one, and let’s connect it to the Modulo.

For the Mac, I use a terminal called “minicom” which is installable via homebrew. Also available on Linux. For any Unix OS (Mac included) you can also use the “screen” utility that’ already installed as well.

The Modulo serial port will look like /dev/tty.usbserial-XXXXXXXX where the Xs are a reasonably-unique alphanumeric string. You can verify you have the right port if “ls /dev/tty.usbserial*” shows the port go away when the modulo is unplugged and come back when it’s plugged in. The serial port on the Modulo is 38400 baud.

If you use “screen” you can connect to the serial port with “screen /dev/tty.usbserial-XXXXXXXX 38400” and pressing enter.

When you’re connected, get a wire jumper or paperclip or something and short pads 2 and 4 on the exposed pads next to the ASR-1 (pad 1 is the one with a square around it, so short, briefly, the pad next to the square pad and then the last pad in the row. The LED will blink again when you hit those pins, which resets the ASR-1. You will also see on the serial port output a copyright notice come out of the ASR-1 and the device’s association ID. This ensures that the ASR-1 not only resets but actually finishes booting and comes ready.

Though to be quite honest, that’s almost assuredly /not/ your problem. :frowning: Interesting info to know, and good to do to be sure, but what we see the vast majority of the time is issues with the BT stack on your mobile. You can try the easy things like toggling BT off and on, or rebooting your phone, but if you can let us know what kind of device you have and waht OS, I’ll dig around with the app guys to see if there are any connectivity issues we’ve seen with your type of device.

Joe


#3

Hi Joe,
Thanks for the quick response. Unfortunately I’ve haven’t had much success communicating to the device via the serial port. I am on a windows 10 machine, so the /dev/tty.usbserial* path didn’t work. When I look in Device Manager, I see a bunch of USB Serial Bus controllers, but no COM ports. I tried using PuTTY to connect to COM1 and COM2 anyway, but that didn’t work. When I unplug and re-insert the Modulo, I don’t see any change in what’s displayed in Device Manager. That makes me think the PC isn’t seeing the device.

To answer your question about the phone, I am using a Motorola G3 running Android 6.0. I tried toggling BT off and on on the phone as well as rebooting the phone.

Finally, I tried removing and then re-adding the Module device to my account but that didn’t make a difference.

On the first night I used the Modulo, I went through both Lesson 1 and Lesson 2. When I published Lesson 2, could that have made it so that Lesson 1 no longer works? I just tried re-Publishing lesson 2 using the Profile Editor, but the profile editor also says the device is offline.

Sigh… I think I broke my new toy.


#4

I don’t think you broke it, but we’ll look at a few other things.

Forgive me if I take a day to set up a windows machine here and see if I can set up the serial debugging stuff on it for you. I haven’t used Windows in a very long time, sorry to say.

There’s on reason why publishing the profile in Lesson 2 would cause the device not to work - unless the OTA to the device went very, very bad, and even in that case the OTA mechanism will still boot the Modulo back to the default profile if the new one doesn’t install properly.

When you see the Modulo in your device list, what does the icon look like? The standard Modulo icon from when it was new, or is it the lamp or whatever the icon is in the Lesson 2 profile?

Joe


#5

Hey Joe - thanks for pulling out your old windows machine! :smile:

I am not seeing the Modulo in my Device list at all.

For grins, I plugged my Arduino Uno into my PC to see how that shows up in device manager, and it shows up under Ports (COM & LPT) as Arduino Uno (COM4). As soon as I plug the Arduino into the USB port, I can see and hear the PC recognizing the device. When I plug the Modulo in, it’s like the PC doesn’t know its there.

I wonder if its a Windows device driver issue. Is Windows 10 supported as a development platform? I am running Windows 10 Home edition (64 bit) on an Acer Aspire VN7-791G


#6

A post was split to a new topic: Added Modulo but can’t see it in the mobile app